Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Typo3 Backend nicht mehr aufrufbar
#1
Hallo zusammen,

ich habe Schritt für Schritt das TYPO3 8 Videotraining durchgearbeitet und wollte heute beim Kapitel 06-03-mehrseitiges-formular-mit-grids_hb weitermachen.

Als ich dann das Backend aufrufen wollte der Schock! (siehe Fehlermeldung unten)
Ich hoffe mir kann jeman schnell bei diesem Problem helfen.



Uncaught TYPO3 Exception
Class 'Standard_action_index_6d642f59e3921e04016bc6c75d4de455036fb29b' not found

Error thrown in file
/var/www/typo3_src-8.7.1/vendor/typo3fluid/fluid/src/Core/Compiler/TemplateCompiler.php in line 165.

14 TYPO3Fluid\Fluid\Core\Compiler\TemplateCompiler::get("Standard_action_index_6d642f59e3921e04016bc6c75d4de455036fb29b")

/var/www/typo3_src-8.7.1/vendor/typo3fluid/fluid/src/Core/Parser/TemplateParser.php:
00180:             $parsedTemplate = $this->parsedTemplates[$templateIdentifier];
00181:         } elseif ($compiler->has($templateIdentifier)) {

00182:             $parsedTemplate = $compiler->get($templateIdentifier);

00183:         } else {
00184:             $parsedTemplate = $this->parse(


13 TYPO3Fluid\Fluid\Core\Parser\TemplateParser::getOrParseAndStoreTemplate("Standard_action_index_6d642f59e3921e04016bc6c75d4de455036fb29b", Closure)

/var/www/typo3_src-8.7.1/vendor/typo3fluid/fluid/src/View/AbstractTemplateView.php:
00361:             function($parent, TemplatePaths $paths) use ($controllerName, $actionName) {
00362:                 return $paths->getTemplateSource($controllerName, $actionName);

00363:             }

00364:         );
00365:         if ($parsedTemplate->isCompiled()) {


12 TYPO3Fluid\Fluid\View\AbstractTemplateView::getCurrentParsedTemplate()

/var/www/typo3_src-8.7.1/vendor/typo3fluid/fluid/src/View/AbstractTemplateView.php:
00176:         }
00177:         try {

00178:             $parsedTemplate = $this->getCurrentParsedTemplate();

00179:         } catch (PassthroughSourceException $error) {
00180:             return $error->getSource();


11 TYPO3Fluid\Fluid\View\AbstractTemplateView::render()

/var/www/typo3_src-8.7.1/typo3/sysext/backend/Classes/Controller/LoginController.php:
00233:
00234:         $content = $this->getDocumentTemplate()->startPage('TYPO3 CMS Login: ' . $GLOBALS['TYPO3_CONF_VARS']['SYS']['sitename']);

00235:         $content .= $this->view->render();

00236:         $content .= $this->getDocumentTemplate()->endPage();
00237:


10 TYPO3\CMS\Backend\Controller\LoginController::main()

/var/www/typo3_src-8.7.1/typo3/sysext/backend/Classes/Controller/LoginController.php:
00138:     public function formAction(ServerRequestInterface $request, ResponseInterface $response)
00139:     {

00140:         $content = $this->main();

00141:         $response->getBody()->write($content);
00142:         return $response;


9 TYPO3\CMS\Backend\Controller\LoginController::formAction(TYPO3\CMS\Core\Http\ServerRequest, TYPO3\CMS\Core\Http\Response)
8 call_user_func_array(array, array)

/var/www/typo3_src-8.7.1/typo3/sysext/backend/Classes/Http/RouteDispatcher.php:
00052:         $targetIdentifier = $route->getOption('target');
00053:         $target = $this->getCallableFromTarget($targetIdentifier);

00054:         return call_user_func_array($target, [$request, $response]);

00055:     }
00056:


7 TYPO3\CMS\Backend\Http\RouteDispatcher::dispatch(TYPO3\CMS\Core\Http\ServerRequest, TYPO3\CMS\Core\Http\Response)

/var/www/typo3_src-8.7.1/typo3/sysext/backend/Classes/Http/RequestHandler.php:
00138:         /** @var RouteDispatcher $dispatcher */
00139:         $dispatcher = GeneralUtility::makeInstance(RouteDispatcher::class);

00140:         return $dispatcher->dispatch($request, $response);

00141:     }
00142: }


6 TYPO3\CMS\Backend\Http\RequestHandler::dispatch(TYPO3\CMS\Core\Http\ServerRequest)

/var/www/typo3_src-8.7.1/typo3/sysext/backend/Classes/Http/RequestHandler.php:
00070:         // Check if the router has the available route and dispatch.
00071:         try {

00072:             return $this->dispatch($request);

00073:
00074:         // When token was invalid redirect to login


5 TYPO3\CMS\Backend\Http\RequestHandler::handleRequest(TYPO3\CMS\Core\Http\ServerRequest)

/var/www/typo3_src-8.7.1/typo3/sysext/core/Classes/Core/Bootstrap.php:
00308:
00309:         // Execute the command which returns a Response object or NULL

00310:         $this->response = $requestHandler->handleRequest($request);

00311:         return $this;
00312:     }


4 TYPO3\CMS\Core\Core\Bootstrap::handleRequest(TYPO3\CMS\Core\Http\ServerRequest)

/var/www/typo3_src-8.7.1/typo3/sysext/backend/Classes/Http/Application.php:
00090:         }
00091:

00092:         $this->bootstrap->handleRequest($this->request);

00093:
00094:         if ($execute !== null) {


3 TYPO3\CMS\Backend\Http\Application::run()

/var/www/typo3_src-8.7.1/typo3/sysext/backend/Resources/Private/Php/backend.php:
00022:     $classLoader = require __DIR__ . '/../../../../../../vendor/autoload.php';
00023:

00024:     (new \TYPO3\CMS\Backend\Http\Application($classLoader))->run();

00025: });


2 {closure}()

/var/www/typo3_src-8.7.1/typo3/sysext/backend/Resources/Private/Php/backend.php:
00023:
00024:     (new \TYPO3\CMS\Backend\Http\Application($classLoader))->run();

00025: });


1 require("/var/www/typo3_src-8.7.1/typo3/sysext/backend/Resources/Private/Php/backend.php")

/var/www/typo3_src-8.7.1/typo3/index.php:
00001: <?php
00002:

00003: require __DIR__ . '/sysext/backend/Resources/Private/Php/backend.php';
Zitieren
#2
Es geht wieder!!!
Ich hab im Install Tool den cache vom typo3temp Folder gelöscht.
Zitieren
#3
Sehr gut. Wie ich immer sage, bei solchen plötzlich auftretenden Fehlern ist das Löschen des Caches und ggf. das Leeren des typo3temp/ Ordners immer die erste Maßnahme. Sehr oft hilft das weiter.
Zitieren
#4
Als nächstes hätte ich dann die Extensions deaktiviert.
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste